Global Data Status Page

This page contains information about closures and delays for all countries, except the US. For US updates, visit data.checkrstatus.com

Widespread outages due to security company CrowdStrike

Incident Report for Checkr Global Data Status

Resolved

The issue impacting International screenings has been resolved and searches are being completed. Please expect some delays and follow https://data.checkrstatus.com/ for any further updates on US and DMV impacts.
Posted Jul 19, 2024 - 23:07 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jul 19, 2024 - 17:57 UTC

Identified

Due to the widespread outages that occurred with the cybersecurity company CrowdStrike, please expect delays. We are continuing to partner with our researchers across the globe to ensure they are able to complete work as quickly as they can. We are closely monitoring this and will keep you updated.

Criminal Records: We have confirmed that some courts, including Los Angeles and Stanislaus, CA, are experiencing outages with their systems resulting in processing delays.

Motor Vehicle Records: We have confirmed that some DMVs are experiencing outages with their systems, resulting in processing delays. These DMVs include: Georgia, Iowa, Kansas, and Wyoming.

The following state DMVs experienced outages but have since recovered: Arizona, Delaware, Indiana, Louisiana, Maryland, New Jersey, Oklahoma, Pennsylvania, Rhode Island, Tennessee, and Virginia.

[Monitoring] International Records: The issue impacting International screenings has been resolved and we are currently monitoring system recovery.
Posted Jul 19, 2024 - 16:29 UTC