Global Data Status Page

This page contains information about closures and delays for all countries, except the US. For US updates, visit data.checkrstatus.com

[Delay] - Canada

Incident Report for Checkr Global Data Status

Resolved

This incident has been resolved.
Posted Jun 02, 2025 - 15:27 UTC

Update

Expect delays due to Victoria Day holiday on 5/19.
Posted May 19, 2025 - 18:13 UTC

Monitoring

Expect delays due to Victoria Day holiday on 5/19.
Posted May 13, 2025 - 16:15 UTC