Global Data Status Page

This page contains information about closures and delays for all countries, except the US. For US updates, visit data.checkrstatus.com

[Delay] - Belarus
Incident Report for Checkr Global Data Status
Resolved
Due to technical issues, please anticiapt
Posted Feb 06, 2025 - 18:57 UTC
Monitoring
Belarus Criminal searches are currently unavailable. We are continuing to monitor this and notify you of any updates and changes we find.
Posted Oct 19, 2023 - 18:57 UTC