Global Data Status Page

This page contains information about closures and delays for all countries, except the US. For US updates, visit data.checkrstatus.com

[Closure] Gibraltar
Incident Report for Checkr Global Data Status
Resolved
Gibraltar territory criminal searches have resumed.
Posted Apr 27, 2023 - 15:55 UTC
Monitoring
8/1/2022: The source for Gibraltar territory is having technical difficulties and have removed services. We will continue to monitor this and notify you of any changes.
Posted Oct 24, 2022 - 15:40 UTC