Global Data Status Page

This page contains information about closures and delays for all countries, except the US. For US updates, visit data.checkrstatus.com

[Delay] - United Kingdom

Incident Report for Checkr Global Data Status

Update

There is a possibility UK orders may be delayed. The team was notified that Scotland has an expected delay of 14-21 days processing time (in addition to standard TAT). We are in the first stages of digging into this and will update when the cause is identified.
Posted Aug 29, 2025 - 21:33 UTC

Investigating

There is a possibility UK orders may be delayed. The team was notified that Scotland has an expected delay of 14-21 days processing time (in addition to standard TAT). We are in the first stages of digging into this and will update when the cause is identified.
Posted Aug 21, 2025 - 19:50 UTC