Global Data Status Page

This page contains information about closures and delays for all countries, except the US. For US updates, visit data.checkrstatus.com

[Delay] - Uganda

Incident Report for Checkr Global Data Status

Resolved

This incident has been resolved.
Posted Aug 21, 2025 - 19:55 UTC

Update

TAT is extended.
Posted Aug 07, 2025 - 19:47 UTC

Update

TAT is extended.
Posted Jul 30, 2025 - 19:13 UTC

Monitoring

TAT is extended.
Posted Jul 21, 2025 - 15:16 UTC