Global Data Status Page

This page contains information about closures and delays for all countries, except the US. For US updates, visit data.checkrstatus.com

[Easter Holiday] - UK, Canada, Australia and Europe

Incident Report for Checkr Global Data Status

Resolved

This incident has been resolved.
Posted Apr 22, 2025 - 16:57 UTC

Update

Expect delays due to court closures for Good Friday on 4/18 & Easter Monday on 4/21.
Posted Apr 18, 2025 - 16:42 UTC

Update

Expect delays due to court closures for Good Friday on 4/18 & Easter Monday on 4/21.
Posted Apr 14, 2025 - 18:05 UTC

Monitoring

Expect delays due to court closures for Good Friday on 4/18 & Easter Monday on 4/21.
Posted Apr 09, 2025 - 17:04 UTC