Global Data Status Page

This page contains information about closures and delays for all countries, except the US. For US updates, visit data.checkrstatus.com

[Delay] - Canadian Drivers License Verification (DLV)

Incident Report for Checkr Global Data Status

Resolved

This incident has been resolved.
Posted Dec 29, 2025 - 20:48 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 24, 2025 - 17:35 UTC

Identified

We've identified an issue affecting a subset of Canadian DLV requests. We're actively working to resolve the issue and all impacted orders will be processed once it's restored.
Posted Dec 23, 2025 - 20:55 UTC