Global Data Status Page

This page contains information about closures and delays for all countries, except the US. For US updates, visit data.checkrstatus.com

E-Verify Technical Difficulties

Incident Report for Checkr Global Data Status

Update

USCIS E-Verify Support has confirmed they are experiencing technical difficulties with their systems. Unfortunately, there is no estimated time for repair at the moment, but E-Verify has stated that they are actively working on the issue. If you experience issues with E-Verify today, please retry processing any impacted E-Verify cases later today or during your next business day.
This only affects the E-Verify module in Tracker I-9 Complete. The Form I-9 modules in the web application are continuing to operate normally, and Employers are still required to complete the Form I-9.
If case submissions to E-Verify are late due to E-Verify’s system outage, E-Verify recommends selecting the “Technical Issues” option when providing a reason why the submission is late.
Posted Oct 23, 2025 - 21:55 UTC

Update

Hello Tracker Administrator,

USCIS E-Verify is experiencing performance issues with their systems today. Unfortunately, there is no estimated time for repair at the moment, but E-Verify has stated that they are actively working on the issue. If you experience issues with E-Verify today, please retry processing any impacted E-Verify cases later today or during your next business day.

This only affects the E-Verify module in Tracker I-9 Complete. The Form I-9 modules in the web application are continuing to operate normally, and Employers are still required to complete the Form I-9.

If case submissions to E-Verify are late due to E-Verify’s performance issues, E-Verify Support recommends selecting the “Technical Issues” option when providing a reason why the submission is late.
Posted Oct 22, 2025 - 19:03 UTC

Update

Dear Tracker I-9 Administrator,

As you may be aware Amazon Web Services (AWS) is experiencing system outages today. The main Tracker I-9 system is not hosted on Amazon Web Services and these outages are not impacting it or Form I-9 processing. However, the Amazon Web Services (AWS) outages, they may impact other related systems and functions of Tracker I-9. Bellow is a list of areas which are or may be impacted by Amazon Web Services (AWS) outages

Amazon Web Services (AWS) outages and performance issues may impact:

Support Portal Login Redirect

USCIS E-Verify: E-Verify does use Amazon Web Services, however E-Verify has not made a statement regarding any impacts to their operations. We are not currently seeing any outage of the USCIS E-Verify system, but we are seeing reduced performance from E-Verify’s systems.

If you experience any issues with E-Verify today, please retry processing your E-Verify cases later today or during your next business day

If E-Verify goes down due to the Amazon Web Services (AWS) outages and case submissions to E-Verify are delayed, E-Verify recommends selecting the “Technical Issues” option when providing a reason why the submission is late.

Email Reminders: At this time we are not seeing issues with Email Reminder on the Tracker I-9 system. However, Tracker I-9 does use Amazon Web Services’ for email reminder management and could be impacted.

Attachments: At this time we are not seeing issues with Attachment on the Tracker I-9 system. However, Tracker I-9 attachment are stored on Amazon Web Services’ hosted systems, and could be impacted.

FlatFile Uploads: At this time we are not seeing issues with FlatFile Uploads to the Tracker I-9 system. However, Tracker I-9 FlatFile Uploads are stored on Amazon Web Services’ hosted systems, and could be impacted.
Posted Oct 20, 2025 - 18:56 UTC

Update

USCIS E-Verify Support has confirmed they are experiencing technical difficulties with their systems. Unfortunately, there is no estimated time for repair at the moment, but E-Verify has stated that they are actively working on the issue. If you experience issues with E-Verify today, please retry processing any impacted E-Verify cases later today or during your next business day.
This only affects the E-Verify module in Tracker I-9 Complete. The Form I-9 modules in the web application are continuing to operate normally, and Employers are still required to complete the Form I-9.
If case submissions to E-Verify are late due to E-Verify’s system outage, E-Verify recommends selecting the “Technical Issues” option when providing a reason why the submission is late.
Posted Oct 16, 2025 - 16:42 UTC

Monitoring

USCIS E-Verify Support has confirmed they are experiencing technical difficulties with their systems. Unfortunately, there is no estimated time for repair at the moment, but E-Verify has stated that they are actively working on the issue. If you experience issues with E-Verify today, please retry processing any impacted E-Verify cases later today or during your next business day.
This only affects the E-Verify module in Tracker I-9 Complete. The Form I-9 modules in the web application are continuing to operate normally, and Employers are still required to complete the Form I-9.
If case submissions to E-Verify are late due to E-Verify’s system outage, E-Verify recommends selecting the “Technical Issues” option when providing a reason why the submission is late.
Posted Oct 14, 2025 - 16:30 UTC