Global Data Status Page

This page contains information about closures and delays for all countries, except the US. For US updates, visit data.checkrstatus.com

[Delay] - India

Incident Report for Checkr Global Data Status

Update

Delays are expected from 10/20 - 10/23 due to Deepawali - Festival of Lights holiday.
Posted Oct 23, 2025 - 21:55 UTC

Monitoring

Delays are expected from 10/20 - 10/23 due to Deepawali - Festival of Lights holiday.
Posted Oct 16, 2025 - 16:36 UTC