Global Data Status Page

This page contains information about closures and delays for all countries, except the US. For US updates, visit data.checkrstatus.com

[Delay] Ukraine Criminal
Incident Report for Checkr Global Data Status
Resolved
This incident has been resolved.
Posted Sep 09, 2024 - 21:46 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 05, 2024 - 15:43 UTC
Investigating
All Criminal checks in Ukraine have been affected by power outages. We are actively monitoring the situation, but we cannot provide an estimate for when this issue will be resolved. Our estimated turnaround time for completion of these checks has increased to 25 days. We will continue to monitor and post any updates here.
Posted Sep 05, 2024 - 15:43 UTC