Global Data Status Page

This page contains information about closures and delays for all countries, except the US. For US updates, visit data.checkrstatus.com

Some users are experiencing issues accessing admin.ca.checkr.com

Incident Report for Checkr Global Data Status

Resolved

This incident has been resolved.
Posted Feb 24, 2026 - 20:31 UTC

Investigating

We are currently investigating this issue.
Posted Feb 24, 2026 - 18:22 UTC