Global Data Status Page

This page contains information about closures and delays for all countries, except the US. For US updates, visit data.checkrstatus.com

Planned Delays - Puerto Rico & Other US Territories
Incident Report for Checkr Global Data Status
Resolved
This incident has been resolved.
Posted Feb 06, 2025 - 18:53 UTC
Monitoring
Delays are expected due to court closures for public holidays on November 19th, 28th, and 29th
Posted Nov 14, 2024 - 13:22 UTC