Effective May 29th NT Northwest Territories connection for Driver License Verification has been restored
Posted May 19, 2025 - 18:14 UTC
Update
Still no access at this time. We will continue to monitor this issue.
Posted May 13, 2025 - 16:12 UTC
Update
Still no access at this time. We will continue to monitor this issue.
Posted May 05, 2025 - 19:58 UTC
Update
Still no access at this time. We will continue to monitor this issue.
Posted Apr 28, 2025 - 20:23 UTC
Update
Still no access at this time. We will continue to monitor this issue.
Posted Apr 22, 2025 - 16:58 UTC
Update
Still no access at this time. We will continue to monitor this issue.
Posted Apr 18, 2025 - 17:05 UTC
Update
Still no access at this time. We will continue to monitor this issue.
Posted Apr 14, 2025 - 18:12 UTC
Monitoring
Still no access at this time. We will continue to monitor this issue.
Posted Apr 09, 2025 - 18:38 UTC
Update
We are continuing to investigate this issue.
Posted Mar 28, 2025 - 17:20 UTC
Investigating
As of March 23, 2025 DLV (Driver License Verification) searches in NWT (North West Territories) Canada are not processing due to local Govt changes. We are monitoring the situation.