Global Data Status Page

This page contains information about closures and delays for all countries, except the US. For US updates, visit data.checkrstatus.com

Global Outages
Incident Report for Checkr Global Data Status
Resolved
This incident has been resolved.
Posted Jul 19, 2024 - 16:29 UTC
Monitoring
With the widespread outages that occurred with the cybersecurity company CrowdStrike, please expect significant delays on manual work and some automated systems. We are continuing to partner with our researchers across the globe to ensure they are able to complete work as quickly as they can. We are closely monitoring this and will keep you updated.
Posted Jul 19, 2024 - 14:58 UTC