Global Data Status Page

This page contains information about closures and delays for all countries, except the US. For US updates, visit data.checkrstatus.com

Unavailable Criminal Searches
Incident Report for Checkr Global Data Status
Resolved
Criminal searches in these are now available.
Posted Feb 01, 2024 - 21:03 UTC
Monitoring
The following countries are currently unavailable for criminal searches: Andora, Burundi, Cuba, Democratic Republic of the Congo, Eritrea, Gabon, Gambia, Haiti, Iraq, Kosovo, Libya, Madagascar, Mali, Mauritania, Monaco, Qatar, Saudi Arabia, Slovenia, Somalia, and Yemen. We are investigating the circumstances around these closures and will continue to provide updates.
Posted Jan 22, 2024 - 21:05 UTC